Thursday, January 29, 2015

Wednesday, January 28, 2015

Error while crawling MySite users wherein MySite Web application is set up with SSL

Error Message:

sps3s://www.domain.com/site$$$people/bucketid=1/itemid=539

An unrecognized HTTP response was received when attempting to crawl this item. Verify whether the item can be accessed using your browser. ( WebExceptionStatus: TrustFailure The underlying connection was closed: Could not establish trust relationship for the SSL/TLS secure channel.; SearchID = 22908598-2E57-4053-96F5-FBB55B029959 )


Solution:

Ensure the SSL cert is registered under "Manage trust" in SharePoint central Admin


Step 1: Export the SSL Certificate
  •  Open the cert from browser. Click on the lock  in address bar 
  • Go to the tab called “Certification Path”, select the root CA certificate and click “View Certificate”
  • Select the “Details” tab and click on “Copy to file”
  • Save the file in your machine

Step 1: Import it in SP Central Admin


  • Go to SP Central Administration  / Security / Manage Trust. Click on “New”, add the root CA certificate from the local machine 



This should do the trick



Monday, January 05, 2015

User Profile not showing up with proper domain name: User profile sync issues

User are showing up with  different domain name after full profile sync.

For e.g . I have all the users defined in ABC domain but after sync some users are showing up as different domain.

expected users in User Profile : ABC\user1
but showing up as : DEF\user1

Note: There is no domain with name DEF but it still shows up that way.

One of the possible reason is Domain netbios name is different than the FQDN of the domain

Check out article below , section Permission requirements: Domain netbios name is different than the FQDN of the domain

http://blogs.msdn.com/b/russmax/archive/2010/03/20/sharepoint-2010-provisioning-user-profile-synchronization.aspx


Profile not found. Tried ~/.bashrc, ~/.bash_profile, ~/.zshrc, and ~/.profile.

Error when installing NPM  Profile not found. Tried ~/.bashrc, ~/.bash_profile, ~/.zshrc, and ~/.profile. Fix: Run command and try a...